Home > .NET > New build server “Microsoft.WebApplication.targets” was not found

New build server “Microsoft.WebApplication.targets” was not found

Just setup a brand new build server with Windows 2008 R2 with TFS 2010 and SQL 2008 R2.

All good except it keep complaint about “Microsoft.WebApplication.targets” was not found When trying to build a web project.

“C:\Builds\1\GrouponSharp\CI\Sources\trunk\GrouponSharp.Web\GrouponSharp.Web.csproj (377): The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.”

Answer was obvious the error says it all. but what do I need to install to get this build target?

Microsoft Visual Studio 2010 Shell (Integrated) Redistributable Package

After installed, the webapplication build target will be appeared in the right directory.

Or even better, you can just install the TFS2010 team explorer on the build server which will install VS 2010 shell redistributable package for you along with other goodies like VS prerequisites.

You don’t need to install the actually visual studio 2010 on your build server like just in order to get this assembly, like some answer you might find on internet.

About these ads
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: